Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 6393) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #6393 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(А. Богданов) Обозначим символом # последовательность цифр, сумма которых равна простому числу P. Среди натуральных чисел, не превышающих 1010, найдите все числа, соответствующие маске 1234# с разными P и делящиеся на (P+2)3. Если для какого-то P найдется несколько чисел, то запишите минимальное из них. В ответе запишите найденные числа в порядке возрастания. Справа от каждого числа соответствующее ему значение P.
Ответ: 12343000 3<br/>123400269 17<br/>123421875 23<br/>1234200000 2<br/>1234509249 29

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.