Задание №16 ЕГЭ: Вычисление рекурсивных функций (ID 6347) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №16 Вариант ЕГЭ Разбор в СмартКИМ

Задание №16: Вычисление рекурсивных функций

Задача #6347 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №16:
Рекурсивные соотношения с мемоизацией Глубокая рекурсия Сумма цифр и чётность

Условие задания

*Обозначим частное от деления натурального числа a на натуральное число b как a // b, а остаток как a%b. Алгоритмы вычисления функций F(n) и G(n) где n – натуральное число, заданы следующими соотношениями:
F(n) = n, если n < 10;
F(n) = F(G(n)), если n ≥ 10;
G(n) = F(n), если n < 10;
G(n) = G(n%10) + G(n//10), если n ≥ 10.
Определите количество таких чисел n, принадлежащих отрезку 100 000 000 ≤ n ≤ 200 000 000, для которых F(n) = 3.
Ответ: 11111111

Общий шаблон задания №16 на Python

# === Задание 16: Рекурсивные функции (Мемоизация) ===
import sys
sys.setrecursionlimit(5000)

memo = {}
def f(n):
    if n in memo: return memo[n]
    if n <= 2: return 1
    if n % 2 == 0:
        res = 2 * n + f(n - 1)
    else:
        res = 3 * n**2 + f(n - 2)
    memo[n] = res
    return res

print("Результат:", f(2024) - f(2020))

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №16.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.