Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 6273) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #6273 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(А. Игнатюк) У исполнителя Д-503 имеются три команды, которым присвоены номера:
1. Прибавь 3
2. Умножь на А
3. Прибавь С
где A и C – натуральные числа, не превышающие 100. Выполняя первую из них, исполнитель увеличивает число на экране на 3, выполняя вторую – умножает на А, выполняя третью – увеличивает на C. Известно, что при выполнении программы 1323123 исполнитель преобразует число 5 в число 329. Определите значения А и С, запишите в ответе их сумму.
Ответ: 13

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.