Задание №19 ЕГЭ: Теория игр: выигрышная стратегия (1 ход) (ID 6204) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №19 Вариант ЕГЭ Разбор в СмартКИМ

Задание №19: Теория игр: выигрышная стратегия (1 ход)

Задача #6204 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №19:
Одна куча камней (Победа за 1 ход) Две кучи камней (Победа Вани за 1 ход)

Условие задания

(Д. Статный) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу два или четыре камня; увеличить количество камней в два раза.
Игра завершается в тот момент, когда количество камней куче становится не менее 100. Игрок, который получил 100 и более камней, считается проигравшим. В начальный момент в куче было S камней; 1 ≤ S ≤ 99.
Ответьте на следующие вопросы:
  Вопрос 1. Укажите минимальное значение S, при котором Петя выигрывает, совершив всего лишь один ход и не используя умножение.
  Вопрос 2. Найдите два минимальных значения S, при которых у Вани есть выигрышная стратегия, причём одновременно выполняются два условия:
— Ваня не может выиграть, совершив один ход;
— Ваня может выиграть, совершив не более двух ходов, независимо от того, как будет ходить Петя.
Найденные значения запишите в ответе в порядке возрастания.
  Вопрос 3. Найдите минимальное и максимальное значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:
— Петя не может выиграть, совершив один ход;
— Петя может выиграть, совершив не более двух ходов, независимо от того, как будет ходить Ваня.
Найденные значения запишите в ответе в порядке возрастания.
Ответ: 1) 94<br/>2) 86 87<br/>3) 46 91

Общий шаблон задания №19 на Python

# === Задания 19-21: Теория игр (1 или 2 кучи) ===
def moves(h):
    return [h + 1, h * 2]

def game(h):
    if h >= 129: return 0  # Победа
    next_g = [game(m) for m in moves(h)]
    if any(g == 0 for g in next_g): return 1  # Победа 1 ходом (П1)
    if all(g == 1 for g in next_g): return 2  # Победа 1 ходом (В1)
    if any(g == 2 for g in next_g): return 3  # Победа 2 ходом (П2)
    if all(g in (1, 3) for g in next_g): return 4  # Победа 2 ходом (В2)
    return -1

for s in range(1, 129):
    res = game(s)
    if res in (1, 2, 3, 4):
        print(f"S={s}: {['П1', 'В1', 'П2', 'В2'][res-1]}")

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №19.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.