Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 6189) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #6189 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(Р. Сорокин) Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:
— символ «#» означает любую последовательность четных цифр произвольной длины; в том числе «#» может задавать и пустую последовательность.
— символ «?» означает одну любую цифру.
Например, маске 1#9? соответствуют числа 190, 146891.
Найдите все натуральные числа, которые не превышают 1011, соответствуют маске 123#45?67 и делятся на 257. В ответе запишите все найденные числа в порядке возрастания, а справа от каждого число – частное от деления этого числа на 257.
Ответ: 123445067 480331<br/>1232245867 4794731<br/>1238645167 4819631<br/>12386045867 48194731

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.