Задание №9 ЕГЭ: Обработка числовых данных в электронных таблицах (ID 6140) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №9 Вариант ЕГЭ Разбор в СмартКИМ

Задание №9: Обработка числовых данных в электронных таблицах

Задача #6140 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №9:
Повторяющиеся и уникальные числа в строке Кратность и геометрические неравенства Поиск максимальных средних значений

Условие задания

В файле электронной таблицы 9-194.xls в каждой строке записаны 5 натуральных чисел. Определите количество строк таблицы, для которых выполнены все условия:
– в строке нет повторяющихся чисел;
– чётных чисел больше, чем нечётных;
– сумма чётных чисел меньше, чем сумма нечётных.
Ответ: 76

Решение на Python: Нет повторов, чётных больше, сумма чётных меньше

count = 0
for line in open("9.txt"):
    row = [int(x) for x in line.split()]
    even = [x for x in row if x % 2 == 0]
    odd = [x for x in row if x % 2 == 1]
    if len(set(row)) == len(row) and len(even) > len(odd) and sum(even) < sum(odd):
        count += 1

print(count)

Этот код разобран по шагам в разборе задания №9: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.