Задание №9 ЕГЭ: Обработка числовых данных в электронных таблицах (ID 6137) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №9 Вариант ЕГЭ Разбор в СмартКИМ

Задание №9: Обработка числовых данных в электронных таблицах

Задача #6137 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №9:
Повторяющиеся и уникальные числа в строке Кратность и геометрические неравенства Поиск максимальных средних значений

Условие задания

В файле электронной таблицы 9-191.xls в каждой строке записаны 6 натуральных чисел. Определите количество строк таблицы, для которых выполнены оба условия:
– в строке есть как повторяющиеся, так и неповторяющиеся числа;
– среднее арифметическое всех неповторяющихся чисел строки больше, чем среднее арифметическое всех повторяющихся чисел этой строки.
При вычислении средних значений каждое число учитывается столько раз, сколько оно встречается в строке.
Ответ: 2114

Решение на Python: Повторяющиеся и неповторяющиеся числа

count = 0
for line in open("9.txt"):
    row = [int(x) for x in line.split()]
    repeated = [x for x in row if row.count(x) > 1]
    single = [x for x in row if row.count(x) == 1]
    if len(repeated) > 0 and len(single) > 0:
        if sum(single) / len(single) > sum(repeated) / len(repeated):
            count += 1

print(count)

Этот код разобран по шагам в разборе задания №9: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.