Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 6101) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #6101 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(А. Богданов) Исполнитель Калькулятор преобразует число, записанное на экране. У исполнителя есть четыре команды, которым присвоены номера:
1. прибавь 1
2. прибавь 3
3. вычти 1
4. вычти 3
Первая из них увеличивает число на экране на 1, вторая - увеличивает его на 3, третья - уменьшает на 1, четвёртая - уменьшает на 3. Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при исходном числе 42 результатом будет являться число 42, при этом траектория вычисления может содержать только числа от 40 до 49, притом каждое число не более одного раза.
Ответ: 85

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.