Задание №17 ЕГЭ: Обработка целочисленных последовательностей (ID 6096) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №17 Вариант ЕГЭ Разбор в СмартКИМ

Задание №17: Обработка целочисленных последовательностей

Задача #6096 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №17:
Поиск пар элементов последовательности Тройки и кортежи чисел Фильтрация по делимости и остаткам

Условие задания

(Д. Статный) В файле 17-362.txt содержится последовательность целых чисел, записанных в позиционных системах исчисления с основаниями от 2 до 36 (для систем с основаниями, большими 10, в качестве цифр используются буквы A, B, C, ..., Z). Будем считать, что основание системы счисления на единицу больше, чем максимальная цифра числа (например, для числа 1A42 основание системы счисления равно A + 1 = 10 + 1 = 11). Парой назовём два подряд идущих элемента последовательности. Определите количество пар, в которых основания систем счисления, в которых записаны числа, отличаются не более чем на 2. В ответ запишите сначала количество таких пар, а затем — максимальную сумму элементов пары (в десятичной системе счисления).
Ответ: 3118 120557282

Общий шаблон задания №17 на Python

# === Задание 17: Обработка числовой последовательности ===
with open('17.txt') as f:
    a = [int(x) for x in f]

# Контрольное значение (например, макс. элемент, оканчивающийся на 13):
max_target = max(x for x in a if abs(x) % 100 == 13)

ans = []
for i in range(len(a) - 1):
    pair = (a[i], a[i+1])
    if sum(1 for x in pair if abs(x) % 100 == 13) == 1:
        if (pair[0]**2 + pair[1]**2) <= max_target**2:
            ans.append(pair[0] + pair[1])

print(f"Количество пар: {len(ans)}, Максимальная сумма: {max(ans)}")

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №17.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.