Задание №16 ЕГЭ: Вычисление рекурсивных функций (ID 6074) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №16 Вариант ЕГЭ Разбор в СмартКИМ

Задание №16: Вычисление рекурсивных функций

Задача #6074 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №16:
Рекурсивные соотношения с мемоизацией Глубокая рекурсия Сумма цифр и чётность

Условие задания

Алгоритм вычисления функции F(n), где n – неотрицательное число, задан следующими соотношениями:
F(n) = 0, если n = 0
F(n) = F(n–1) + 5·n.
Найдите количество таких чисел в диапазоне от 189 456 678 до 567 654 321, для которых F(n) не делится на 7.
Ответ: 270141174

Решение на Python: Считаем по остаткам вместо перебора

a = 189456678
b = 567654321

total = 0
for r in range(7):
    n = 700 + r
    if 5 * n * (n + 1) // 2 % 7 != 0:
        first = a + (r - a) % 7
        total += (b - first) // 7 + 1

print(total)

Этот код разобран по шагам в разборе задания №16: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.