Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 6023) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #6023 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(И. Карпачев) Исполнитель Калькулятор преобразует число, записанное на экране. У исполнителя есть две команды, которым присвоены коды:
A. Умножь на 2
B. Прибавь 2
Первая команда увеличивает число в 2 раза, вторая – на 2. Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при исходном числе 4 результатом будет являться число 42, при этом траектория вычисления не содержит подпоследовательность команд BBA. Траектория вычисления программы – это последовательности результатов выполнения всех команд. Например, для программы ABA при исходном числе 4 траектория будет состоять из чисел 8, 10, 20.
Ответ: 10

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.