Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5956) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5956 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(Д. Статный) Среди натуральных чисел, не превышающих 109, найдите все числа, делящиеся на 2023, у которых первые 6 делителей, отличные от самого числа и единицы, попарно просты (не имеют общих делителей, кроме 1). В ответ укажите в порядке возрастания наименьшие 5 таких чисел, а также наибольшие 5 таких чисел. Справа от каждого числа укажите его максимальный делитель, отличный от самого числа.
Ответ: 16489473 5496491<br/>27482455 5496491<br/>33268235 6653647<br/>41946905 8389381<br/>44839795 8967959<br/>979874441 139982063<br/>986275213 140896459<br/>992550559 141792937<br/>993812911 141973273<br/>994464317 142066331

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.