Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5842) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5842 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(Д. Статный) Среди натуральных чисел, принадлежащих промежутку [100 000 000; 1 000 000 000], найдите все числа, имеющие ровно 15 делителей, делящихся на 7 и отличных самого числа. В ответ запишите 5 наименьших и 5 наибольших найденных чисел в порядке возрастания, справа от них укажите их максимальный делитель, отличный от самого числа.
Ответ: 100000054 50000027<br/>100000131 33333377<br/>100000222 50000111<br/>100000250 50000125<br/>100000264 50000132<br/>999999791 142857113<br/>999999798 499999899<br/>999999854 499999927<br/>999999875 199999975<br/>999999896 499999948

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.