Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5841) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5841 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(Д. Статный) Среди натуральных чисел, принадлежащих промежутку [100 000 000; 200 000 000], найдите все числа, имеющие ровно 7 делителей, делящихся на 2022 и отличных от самого числа. В ответ запишите 5 наименьших и 5 наибольших найденных чисел в порядке возрастания, справа от них укажите их максимальный делитель, отличный от самого числа.
Ответ: 100004076 50002038<br/>100012164 50006082<br/>100018230 50009115<br/>100022274 50011137<br/>100026318 50013159<br/>199947492 99973746<br/>199963668 99981834<br/>199981866 99990933<br/>199985910 99992955<br/>199987932 99993966

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.