Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5766) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5766 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(Д. Статный) Среди натуральных чисел, принадлежащих промежутку [100 000 000; 500 000 000], найдите все числа, имеющие ровно 7 делителей, отличных от 1 и самого числа. В ответ запишите 5 наибольших из найденных чисел в порядке возрастания, справа от каждого числа запишите его максимальный делитель, отличный от самого числа.
Ответ: 499164964 249582482<br/>499343716 249671858<br/>499656609 166552203<br/>499701316 249850658<br/>499835449 6327031

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.