Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5764) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5764 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(Д. Статный) Среди натуральных чисел, принадлежащих отрезку [35 000 000; 100 000 000], найдите все числа, имеющие ровно 5 нечётных делителей (количество чётных делителей неважно). В ответ запишите первые 5 таких чисел числа в порядке возрастания, справа от каждого числа запишите его максимальный нечётный делитель.
Ответ: 35819648 279841<br/>38950081 38950081<br/>39037448 4879681<br/>39337984 2401<br/>40302242 20151121

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.