Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5763) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5763 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(Д. Статный) Найдите все натуральные числа, принадлежащие отрезку [10 000 000; 60 000 000], у которых количество делителей – простое число. В ответе запишите первые 7 чисел с наибольшим количеством делителей, справа от каждого числа запишите количество его делителей. Отсортируйте числа по убыванию количества делителей, а числа с одинаковым количеством делителей – по возрастанию самих чисел.
Ответ: 43046721 17<br/>24137569 7<br/>47045881 7<br/>12117361 5<br/>13845841 5<br/>20151121 5<br/>25411681 5

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.