Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5762) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5762 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(Д. Статный) Найдите все четные натуральные числа, принадлежащие полуинтервалу [100 000 000; 1 000 000 000), у которых ровно 39 делителей. В ответ запишите сначала наименьшие 5, а затем – наибольшие 5 таких чисел в порядке возрастания; справа от каждого числа укажите его максимальный нечётный делитель.
Ответ: 100962304 24649<br/>108826624 26569<br/>114233344 27889<br/>122589184 29929<br/>131239936 32041<br/>893292544 218089<br/>939790336 229441<br/>971444224 237169<br/>976562500 244140625<br/>987467776 241081

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.