Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5752) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5752 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(М. Ишимов) Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:
— символ «?» означает ровно одну произвольную цифру;
— символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.
Например, маске 123*4?5 соответствуют числа 123405 и 12300405. Среди натуральных чисел, не превышающих 109, найдите все числа, соответствующие маске 15*3*09 и имеющие ровно 9 делителей. В ответе запишите в первом столбце таблицы все найденные числа в порядке возрастания, а во втором столбце – соответствующие им максимальные делители, не считая самого числа.
Ответ: 15233409 5077803<br/>153834409 1947271<br/>158835609 52945203

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.