Задание №15 ЕГЭ: Истинность логических выражений на отрезках и множествах (ID 5672) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №15 Вариант ЕГЭ Разбор в СмартКИМ

Задание №15: Истинность логических выражений на отрезках и множествах

Задача #5672 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №15:
Числовые отрезки Множества натуральных чисел Поразрядная конъюнкция (&) Делимость (ДЕЛ)

Условие задания

(А. Кабанов) Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m» ; и пусть на числовой прямой дан отрезок B = [10; 40]. Найдите наименьшую возможную длину отрезка A, при котором формула

(x ∈ A) ∨ ((x ∈ B) → ¬ДЕЛ(x, 6))

тождественно истинна, то есть принимает значение 1 при любом натуральном значении переменной х?
Ответ: 24

Решение на Python: Делимость и отрезок: длина A

need = []
for x in range(10, 41):
    if x % 6 == 0:
        need.append(x)

print(max(need) - min(need))

Этот код разобран по шагам в разборе задания №15: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.