Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5378) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5378 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(ЕГЭ-2022) Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:
— символ «?» означает ровно одну произвольную цифру;
— символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.
Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 12*4?65, делящиеся на 161 без остатка. В ответе запишите в первом столбце таблицы все найденные числа в порядке возрастания, а во втором столбце – соответствующие им результаты деления этих чисел на 161.
Ответ: 1234065 7665<br/>12004965 74565<br/>12214265 75865<br/>12294765 76365<br/>12504065 77665<br/>12584565 78165<br/>12874365 79965<br/>12954865 80465

Решение на Python: Боевой шаблон решения на Python

from fnmatch import fnmatch

for n in range(161, 10 ** 8 + 1, 161):
    if fnmatch(str(n), "12*4?65"):
        print(n, n // 161)

Этот код разобран по шагам в разборе задания №25: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.