Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5289) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5289 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(М. Фирсов) Пусть D(N) – наибольший делитель числа N, отличный от самого числа, и Q(N) – записанная в обратном порядке сумма всех его простых сомножителей (необязательно различных). Найдите первые 5 натуральных чисел N, для которых N + D(N) + Q(N) > 202122. В ответе запишите все найденные числа в порядке возрастания, справа от каждого запишите сумму D(N) + Q(N) для этого N.
Ответ: 68594 133540<br/>69374 133330<br/>69754 132720<br/>69794 134740<br/>71194 135150

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.