Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 5064) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #5064 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(А. Сапегин) Исполнитель Ландыш преобразует пару чисел, записанную на экране. У исполнителя Ландыш есть четыре команды:
1. Прибавь к первому числу 3
2. Умножь первое число на 4
3. Прибавь ко второму числу 5
4. Умножь второе число на 2
Первая из них увеличивает первое число из пары на 2, вторая – умножает его на 4. Третья команда увеличивает второе число из пары на 5, четвертая – умножает его на 2. Сколько различных пар взаимно простых чисел можно получить из пары чисел (2, 3) с помощью программы, которая состоит ровно из 5 команд? Пары, отличающиеся только перестановкой чисел, считать одинаковыми.
Ответ: 103

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.