Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 5027) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #5027 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(PRO100 ЕГЭ) Найдите все натуральные числа, принадлежащие отрезку [1 000 000 000 ; 2 000 000 000], которые заканчиваются на цифру 8 и имеют больше 100 различных нечётных делителей (количество чётных делителей может быть любым). И при этом число должно делиться на каждое из чисел: 7, 13, 17, 23, 29, но не делиться ни на 3, ни на 5. В ответе запишите найденные числа в порядке возрастания, а справа от каждого числа – его наибольший нечётный делитель.
Ответ: 1384741358 692370679<br/>1611748138 805874069<br/>1725251528 215656441<br/>1921302838 960651419<br/>1952258308 488064577

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.