Задание №17 ЕГЭ: Обработка целочисленных последовательностей (ID 5022) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №17 Вариант ЕГЭ Разбор в СмартКИМ

Задание №17: Обработка целочисленных последовательностей

Задача #5022 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №17:
Поиск пар элементов последовательности Тройки и кортежи чисел Фильтрация по делимости и остаткам

Условие задания

(В. Селезнёв) В файле 17-281.txt содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от 1 до 10 000 включительно. Рассматриваются шестерки идущих подряд чисел, в которых первые три элемента образуют возрастающую арифметическую прогрессию, а последние три элемента – возрастающую геометрическую, или наоборот – первые три элемента образуют возрастающую геометрическую прогрессию, а последние три – возрастающую арифметическую прогрессию. Выберите такие из указанных шестёрок чисел, для которых знаменатель геометрической прогрессии такой же, как и разность арифметической прогрессии. В ответе запишите два числа: сначала количество подходящих шестёрок, а затем наибольшую из их сумм.
Ответ: 24 27600

Общий шаблон задания №17 на Python

# === Задание 17: Обработка числовой последовательности ===
with open('17.txt') as f:
    a = [int(x) for x in f]

# Контрольное значение (например, макс. элемент, оканчивающийся на 13):
max_target = max(x for x in a if abs(x) % 100 == 13)

ans = []
for i in range(len(a) - 1):
    pair = (a[i], a[i+1])
    if sum(1 for x in pair if abs(x) % 100 == 13) == 1:
        if (pair[0]**2 + pair[1]**2) <= max_target**2:
            ans.append(pair[0] + pair[1])

print(f"Количество пар: {len(ans)}, Максимальная сумма: {max(ans)}")

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №17.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.