Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 4947) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #4947 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

Особыми будем называть нетривиальные делители числа, все цифры которых нечётные. Нетривиальными считаются все делители, кроме 1 и самого числа. Пусть D(N) – пятый по величине (считая с наибольшего) особый делитель натурального числа N. Если у числа N меньше пяти различных особых делителей, то принимаем D(N) = 0. Найдите 5 наибольших натуральных чисел, меньших 300 000 000, для которых D(N) > 0. В ответе запишите для каждого найденного N сначала значение D(N), а затем общее количество особых делителей (в порядке возрастания соответствующих чисел N).
Ответ: 1195 11<br/>39 8<br/>5 5<br/>5 6<br/>9999 16

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.