Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 4940) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #4940 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

Пусть D(N) – шестой по величине (считая с наибольшего) нетривиальный чётный делитель натурального числа N (нетривиальными считаются все делители, кроме 1 и самого числа). Например, D(1000) = 40. Если у числа N меньше 6 различных нетривиальных чётных делителей, то принимаем D(N) = 0. Найдите 5 наименьших натуральных чисел, превышающих 300 000 000, для которых D(N) > 0. В ответе запишите для каждого найденного N сначала значение D(N), а затем общее количество нетривиальных чётных делителей (в порядке возрастания соответствующих чисел N).
Ответ: 4 7<br/>405954 23<br/>13636364 23<br/>10344828 47<br/>118 7

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.