Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 4846) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #4846 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(Б. Михлин) Исполнитель К22 преобразует число, записанное на экране. У исполнителя есть три команды, которым присвоены номера:
1. Прибавь 1
2. Прибавь 4
3. Получи факториал следующего числа
Первая из них увеличивает число на экране на 1, вторая увеличивает число на 4. Факториалом числа N (обозначается как N!) называют произведение всех натуральных чисел от 1 до N. Третья команда заменяет число N на факториал следующего числа, т.е. на факториал (N+1). Например, для числа N=3 будет получено 24 = (3+1)! 1·2·3·4). Программа для исполнителя – это последовательность команд. Сколько существует программ, которые преобразуют исходное число 2 в число 24, и при этом траектория вычислений не содержит число 12?
Ответ: 371

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.