Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 4745) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #4745 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

Пусть S (N) – сумма трёх наибольших нетривиальных делителей числа N (не считая единицы и самого числа). Если у числа N меньше трёх таких делителей, то S (N) считается равным 0. Найдите 5 наименьших натуральных чисел, превышающих 10 000 000, для которых S (N) – простое число. 1) В ответе запишите найденные числа в порядке возрастания, справа от каждого числа запишите соответствующее ему значение S(N).
Ответ: 10000495 2014799<br/>10000601 792131<br/>10000604 7500457<br/>10000847 273059<br/>10000917 4444861

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.