Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 4744) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #4744 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

Пусть S (N) – сумма двух наибольших нетривиальных делителей числа N (не считая единицы и самого числа). Если у числа N меньше двух таких делителей, то S (N) считается равным 0. Найдите 5 наименьших натуральных чисел, превышающих 10 000 000, для которых S (N) меньше, чем 100 000, и десятичная запись этого числа оканчивается на 112. В ответе запишите найденные числа в порядке возрастания, справа от каждого числа запишите соответствующее ему значение S(N).
Ответ: 10011007 7112<br/>10012007 56112<br/>10023487 22112<br/>10028327 92112<br/>10042367 23112

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.