Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 4210) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #4210 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(А. Комков) Пусть A – абсолютное значение разности максимального четного и максимального нечетного делителей числа, не считая единицы и самого числа. Если хотя бы одного из таких делителей у числа нет, то считаем значение A равным нулю. Напишите программу, которая перебирает целые числа, большие 250156, в порядке возрастания и ищет среди них первые 5, для которых значение A является простым числом, оканчивающимся на 9. Для каждого из найденных чисел в отдельной строке сначала выводить само число, затем значение A. Строки выводятся в порядке возрастания найденных чисел.
Ответ: 250196 62549<br/>250314 41719<br/>250374 41729<br/>250442 125219<br/>250554 41759

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.