Задание №19 ЕГЭ: Теория игр: выигрышная стратегия (1 ход) (ID 4035) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №19 Вариант ЕГЭ Разбор в СмартКИМ

Задание №19: Теория игр: выигрышная стратегия (1 ход)

Задача #4035 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №19:
Одна куча камней (Победа за 1 ход) Две кучи камней (Победа Вани за 1 ход)

Условие задания

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в любую кучу один камень или увеличить количество камней в любой куче в три раза. Игра завершается в тот момент, когда общее количество камней в двух кучах становится не менее 99. Победителем считается игрок, сделавший последний ход. В начальный момент в первой куче было 8 камней, а во второй – S камней, 1 ≤ S ≤ 90.
Ответьте на следующие вопросы:
  Вопрос 1. Известно, что Ваня выиграл своим первым ходом после первого хода Пети. Назовите минимальное значение S, при котором это возможно.
  Вопрос 2. Определите, сколько существует таких значений S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:
− Петя не может выиграть за один ход;
− Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.
  Вопрос 3. Укажите максимальное значение S, при котором у Вани есть выигрышная стратегия, позволяющая ему выиграть при любой игре Пети.
Ответ: 1) 11<br/>2) 3<br/>3) 30

Общий шаблон задания №19 на Python

# === Задания 19-21: Теория игр (1 или 2 кучи) ===
def moves(h):
    return [h + 1, h * 2]

def game(h):
    if h >= 129: return 0  # Победа
    next_g = [game(m) for m in moves(h)]
    if any(g == 0 for g in next_g): return 1  # Победа 1 ходом (П1)
    if all(g == 1 for g in next_g): return 2  # Победа 1 ходом (В1)
    if any(g == 2 for g in next_g): return 3  # Победа 2 ходом (П2)
    if all(g in (1, 3) for g in next_g): return 4  # Победа 2 ходом (В2)
    return -1

for s in range(1, 129):
    res = game(s)
    if res in (1, 2, 3, 4):
        print(f"S={s}: {['П1', 'В1', 'П2', 'В2'][res-1]}")

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №19.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.