Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 3933) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #3933 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(Е. Джобс) Напишите программу, которая находит 6 простых чисел наиболее приближенные к числу 10000000 (10 миллионов). Причем 3 найденных числа должны быть меньше 10000000, остальные 3 числа – больше. Найденные числа расположите в порядке возрастания. В качестве ответа выведите пары чисел – расстояние от найденного числа до 10000000 и само число.
Ответ: 29 9999971<br/>27 9999973<br/>9 9999991<br/>19 10000019<br/>79 10000079<br/>103 10000103

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.