Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 3657) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #3657 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(С.О. Куров) Среди целых чисел, принадлежащих числовому отрезку [1000000; 1300000], найдите числа, у которых все цифры меньше тройки, а сумма цифр кратна десяти. Среди всех таких чисел необходимо отобрать каждое десятое (10-е, 20-е, 30-е и т.д.). Расположите найденные числа в порядке возрастания, справа от каждого числа укажите количество его собственных делителей (не равных 1 и самому числу).
Ответ: 1112221 2<br/>1122220 22<br/>1212112 38<br/>1221121 6<br/>1222210 30

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.