Задание №13 ЕГЭ: Динамика и количество программ (ID 2765) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №13 Вариант ЕГЭ Разбор в СмартКИМ

Задание №13: Динамика и количество программ

Задача #2765 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №13:
Количество программ Обязательные и запрещённые этапы Динамика по состояниям

Условие задания

Исполнитель Калькулятор преобразует число на экране. У исполнителя есть три команды, которым присвоены номера:
1. Прибавить 1
2. Прибавить 4
3. Умножить на 2
Программа для исполнителя Калькулятор – это последовательность команд. Сколько существует программ, состоящих из 7 команд, для которых при исходном числе 3 результатом является число 27?
Ответ: 37

Решение на Python: Программы из ровно 7 команд

ways = {3: 1}

for step in range(7):
    new_ways = {}
    for value in ways:
        for result in (value + 1, value + 4, value * 2):
            if result not in new_ways:
                new_ways[result] = 0
            new_ways[result] += ways[value]
    ways = new_ways

print(ways.get(27, 0))

Этот код разобран по шагам в разборе задания №13: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.