Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 2585) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #2585 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(А.Н. Носкин) Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [2532000; 2532160] первые пять простых чисел. Выведите найденные простые числа в порядке возрастания, слева от каждого числа выведите его номер по порядку.
Ответ: 1 2532007<br/>2 2532067<br/>3 2532071<br/>4 2532083<br/>5 2532107

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.