Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 2564) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #2564 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [194455; 194500], числа, имеющие ровно 4 различных делителя. В ответе для каждого найденного числа запишите два его наибольших делителя в порядке возрастания.
Ответ: 38891 194455<br/>1193 194459<br/>1399 194461<br/>97231 194462<br/>1721 194473<br/>443 194477<br/>97241 194482<br/>4523 194489<br/>17681 194491

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.